用户
 找回密码
 立即注册

2

主题

3

帖子

204

积分

中级会员

Rank: 3Rank: 3

积分
204
发表于 2020-3-26 19:36:22
Smobiler 5.0

New MobileServer()
初始化的时候报错


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
使用道具 举报 回复
项目中使用的dll是\Smobiler Designer\LibraryCore下的吗?
designer安装目录下有两个文件夹Library和LibraryCore,LibraryCore才是net core下的dll
使用道具 举报 回复 支持 反对
引用Library下的DLL文件,没问题。
引用LibraryCore下的DLL文件,编译的时候报错:
类型“System.ComponentModel.Component”在未被引用的程序集中定义。必须添加对程序集“System.ComponentModel.Primitives, Version=4.2.1.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a”的引用。

通过NuGet引用了System.ComponentModel.Primitives(4.3.0版本),再编译,提示版本冲突:一个是4.2.1.0版本,一个是4.1.1.0版本。
查看System.ComponentModel.Primitives的属性,版本是4.1.1.0。也就是说安装的是4.3.0版本,实际是4.1.1.0版本。

这是啥情况啊。
使用道具 举报 回复 支持 反对
发新帖
您需要登录后才可以回帖 登录 | 立即注册